package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)\s*(?:(\w+)?)(?:(\.\w+)?)$`)
var str = `000035 ZSMS_1.mp3
000035 1OMNA
000035`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}