// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+)\s*(?:(\w+)?)(?:(\.\w+)?)$").unwrap();
let string = "000035 ZSMS_1.mp3
000035 1OMNA
000035";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}