#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "log-((?!wuble-wamwam|monkey).*?)-[0-9]{4}\.[0-9]{2}"
Local $sString = "log-widget-alpha-2017.01" & @CRLF & _
"log-doodad-wubwub-2017.01" & @CRLF & _
"log-widget-alpha-2017.02" & @CRLF & _
"log-doodad-wubwub-2017.02" & @CRLF & _
"log-wuble-wamwam-2017.01" & @CRLF & _
"log-monkey-2017.01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")