const regex = /log-((?!wuble-wamwam|monkey).*?)-[0-9]{4}\.[0-9]{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('log-((?!wuble-wamwam|monkey).*?)-[0-9]{4}\\.[0-9]{2}', 'g')
const str = `log-widget-alpha-2017.01
log-doodad-wubwub-2017.01
log-widget-alpha-2017.02
log-doodad-wubwub-2017.02
log-wuble-wamwam-2017.01
log-monkey-2017.01`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}