$re = '/log-((?!wuble-wamwam|monkey).*?)-[0-9]{4}\.[0-9]{2}/';
$str = 'log-widget-alpha-2017.01
log-doodad-wubwub-2017.01
log-widget-alpha-2017.02
log-doodad-wubwub-2017.02
log-wuble-wamwam-2017.01
log-monkey-2017.01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);