using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"log-((?!wuble-wamwam|monkey).*?)-[0-9]{4}\.[0-9]{2}";
string input = @"log-widget-alpha-2017.01
log-doodad-wubwub-2017.01
log-widget-alpha-2017.02
log-doodad-wubwub-2017.02
log-wuble-wamwam-2017.01
log-monkey-2017.01";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}