package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mUs){:de}(.*){:}`)
var str = `{:de}Hallo Welt{:}{:en}Helo world{:}{:de}Hallo Welt{:}{:en}Helo world{:}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}