re = /{:de}(.*){:}/m
str = '{:de}Hallo Welt{:}{:en}Helo world{:}{:de}Hallo Welt{:}{:en}Helo world{:}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end