$re = '/{:de}(.*){:}/mUs';
$str = '{:de}Hallo Welt{:}{:en}Helo world{:}{:de}Hallo Welt{:}{:en}Helo world{:}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);