const regex = /{:de}(.*){:}/ms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{:de}(.*){:}', 'ms')
const str = `{:de}Hallo Welt{:}{:en}Helo world{:}{:de}Hallo Welt{:}{:en}Helo world{:}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}