#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\w*house\w*\b.*\.(?:jpg|png|gif)$"
Local $sString = "zt_housedsaf-34.png" & @CRLF & _
"housedsaf-34.gif" & @CRLF & _
"" & @CRLF & _
"house.gif" & @CRLF & _
"123house.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")