re = /\b\w*house\w*\b.*\.(?:jpg|png|gif)$/m
str = 'zt_housedsaf-34.png
housedsaf-34.gif
house.gif
123house.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end