package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\w*house\w*\b.*\.(?:jpg|png|gif)$`)
var str = `zt_housedsaf-34.png
housedsaf-34.gif
house.gif
123house.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}