using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\w*house\w*\b.*\.(?:jpg|png|gif)$";
string input = @"zt_housedsaf-34.png
housedsaf-34.gif
house.gif
123house.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}