using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Validate control value for ELEMENT - (?<control>.*?)as (?<fields>.*)";
string input = @" Validate control value for ELEMENT - VerifyFirstRowSearchNotes as ~Creating Stat Reserve: ~IP: Claimant Driver; IP Role(s): Owner, Driver~Exposure";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}