package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Validate control value for ELEMENT - (?<control>.*?)as (?<fields>.*)`)
var str = ` Validate control value for ELEMENT - VerifyFirstRowSearchNotes as ~Creating Stat Reserve: ~IP: Claimant Driver; IP Role(s): Owner, Driver~Exposure`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}