re = /Validate control value for ELEMENT - (?<control>.*?)as (?<fields>.*)/
str = ' Validate control value for ELEMENT - VerifyFirstRowSearchNotes as ~Creating Stat Reserve: ~IP: Claimant Driver; IP Role(s): Owner, Driver~Exposure'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end