use strict;
my $str = 'BradMoon-PGT-2017-02-04_to_2017-02-10';
my $regex = qr/(BradMoon-PGT-2017)\-(\d\d)\-(\d\d)\_to\_(2017)\-(\d\d)\-(\d\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}