re = /(BradMoon-PGT-2017)\-(\d\d)\-(\d\d)\_to\_(2017)\-(\d\d)\-(\d\d)/
str = 'BradMoon-PGT-2017-02-04_to_2017-02-10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end