#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:###|\*\*\* Entry).*"
Local $sString = "*** Entry 4 *** 05-17-2021 08:05:36" & @CRLF & _
"And" & @CRLF & _
"" & @CRLF & _
"### Scrambled GET_DEVICE_INFO response ###" & @CRLF & _
"### VIEW_LOG_RADIO EnabledE(¾ç@VENT_CRIT_MANUF 8 ###"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")