re = /^(?:###|\*\*\* Entry).*/m
str = '*** Entry 4 *** 05-17-2021 08:05:36
And
### Scrambled GET_DEVICE_INFO response ###
### VIEW_LOG_RADIO EnabledE(¾ç@VENT_CRIT_MANUF 8 ###'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end