package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:###|\*\*\* Entry).*`)
var str = `*** Entry 4 *** 05-17-2021 08:05:36
And
### Scrambled GET_DEVICE_INFO response ###
### VIEW_LOG_RADIO EnabledE(¾ç@VENT_CRIT_MANUF 8 ###`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}