import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:###|\\*\\*\\* Entry).*";
final String string = "*** Entry 4 *** 05-17-2021 08:05:36\n"
+ "And\n\n"
+ "### Scrambled GET_DEVICE_INFO response ###\n"
+ "### VIEW_LOG_RADIO EnabledE(¾ç@VENT_CRIT_MANUF 8 ###";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}