package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)xxx=\"([A-Za-z]+)\"`)
var str = `<tagname xxx="UhYklioLLkhRRttyNN" />`
var substitution = "xxx="\L$1""
fmt.Println(re.ReplaceAllString(str, substitution))
}