const regex = /xxx=\"([A-Za-z]+)\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('xxx=\\"([A-Za-z]+)\\"', 'gm')
const str = `<tagname xxx="UhYklioLLkhRRttyNN" />`;
const subst = `xxx="\L$1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);