$re = '/xxx=\"([A-Za-z]+)\"/m';
$str = '<tagname xxx="UhYklioLLkhRRttyNN" />';
$subst = "xxx=\"\L$1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;