using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^.\n]*\.([^.\n]+)\..*";
string substitution = @"\1";
string input = @"Marketing Analyst
501.Software Engineer.MG3
Product Researcher
Managing Director
64.Legal Consultant.I44
Hardware Analyst.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}