import Foundation
let pattern = #"^[^.\n]*\.([^.\n]+)\..*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Marketing Analyst
501.Software Engineer.MG3 
Product Researcher
Managing Director
64.Legal Consultant.I44
Hardware Analyst.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)