$re = '/^[^.\n]*\.([^.\n]+)\..*/m';
$str = 'Marketing Analyst
501.Software Engineer.MG3
Product Researcher
Managing Director
64.Legal Consultant.I44
Hardware Analyst.';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;