package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(nightly|beta|stable|\d{1}\.\d{1,3}(?:\.\d{1,2})?)(?:-(\d{4}-\d{2}-\d{2}))?(?:-(.+))?$`)
var str = `nightly-2024-01-25`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}