import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(nightly|beta|stable|\\d{1}\\.\\d{1,3}(?:\\.\\d{1,2})?)(?:-(\\d{4}-\\d{2}-\\d{2}))?(?:-(.+))?$";
final String string = "nightly-2024-01-25";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}