re = /^(nightly|beta|stable|\d{1}\.\d{1,3}(?:\.\d{1,2})?)(?:-(\d{4}-\d{2}-\d{2}))?(?:-(.+))?$/m
str = 'nightly-2024-01-25'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end