// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(nightly|beta|stable|\d{1}\.\d{1,3}(?:\.\d{1,2})?)(?:-(\d{4}-\d{2}-\d{2}))?(?:-(.+))?$").unwrap();
let string = "nightly-2024-01-25";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}