package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\n(?:\\n|\s)*`)
var str = `save
11
\nabc
\nabc
\nhello
\n\n
dfcs dcsd
\n\n
sdcsd
\nsdcsdc
\nsdcd
\n
1
\n\n
11
\n111
\n\n
1111
\n11111
\n\n
1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}