use strict;
my $str = 'save
11
\\nabc
\\nabc
\\nhello
\\n\\n
dfcs dcsd
\\n\\n
sdcsd
\\nsdcsdc
\\nsdcd
\\n
1
\\n\\n
11
\\n111
\\n\\n
1111
\\n11111
\\n\\n
1
';
my $regex = qr/\n(?:\\n|\s)*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}