const regex = /\n(?:\\n|\s)*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n(?:\\\\n|\\s)*', 'g')
const str = `save
11
\\nabc
\\nabc
\\nhello
\\n\\n
dfcs dcsd
\\n\\n
sdcsd
\\nsdcsdc
\\nsdcd
\\n
1
\\n\\n
11
\\n111
\\n\\n
1111
\\n11111
\\n\\n
1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}