$re = '/\n(?:\\\\n|\s)*/';
$str = 'save
11
\\nabc
\\nabc
\\nhello
\\n\\n
dfcs dcsd
\\n\\n
sdcsd
\\nsdcsdc
\\nsdcd
\\n
1
\\n\\n
11
\\n111
\\n\\n
1111
\\n11111
\\n\\n
1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);