using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)=(?:\'?)([^\']+)(?:\'?)\s";
string input = @"Key1='value1' Key2='value' Key3='value with space' Key4=value_without_quotes
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}