$re = '/(\w+)=(?:\'?)([^\']+)(?:\'?)\s/';
$str = 'Key1=\'value1\' Key2=\'value\' Key3=\'value with space\' Key4=value_without_quotes
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);