// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+)=(?:\'?)([^\']+)(?:\'?)\s").unwrap();
let string = "Key1='value1' Key2='value' Key3='value with space' Key4=value_without_quotes
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}