re = /(\w+)=(?:\'?)([^\']+)(?:\'?)\s/
str = 'Key1=\'value1\' Key2=\'value\' Key3=\'value with space\' Key4=value_without_quotes
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end