import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{6,16}$)[a-zA-Z][a-zA-Z0-9]*(?:-[a-zA-Z0-9]+)?$";
final String string = "a-aaaa\n"
+ "aaaaaa\n"
+ "Aaaaaaaaaaaaaaaa\n"
+ "A-dddddddddddddd\n\n"
+ "A-a-aaaaaaaaaaaa\n"
+ "a-aaaaaaaaaa-\n"
+ "-aaaaaaaaaa\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}