const regex = /^(?=.{6,16}$)[a-zA-Z][a-zA-Z0-9]*(?:-[a-zA-Z0-9]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{6,16}$)[a-zA-Z][a-zA-Z0-9]*(?:-[a-zA-Z0-9]+)?$', 'gm')
const str = `a-aaaa
aaaaaa
Aaaaaaaaaaaaaaaa
A-dddddddddddddd
A-a-aaaaaaaaaaaa
a-aaaaaaaaaa-
-aaaaaaaaaa
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}