re = /^(?=.{6,16}$)[a-zA-Z][a-zA-Z0-9]*(?:-[a-zA-Z0-9]+)?$/m
str = 'a-aaaa
aaaaaa
Aaaaaaaaaaaaaaaa
A-dddddddddddddd
A-a-aaaaaaaaaaaa
a-aaaaaaaaaa-
-aaaaaaaaaa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end