$re = '/^(?=.{6,16}$)[a-zA-Z][a-zA-Z0-9]*(?:-[a-zA-Z0-9]+)?$/m';
$str = 'a-aaaa
aaaaaa
Aaaaaaaaaaaaaaaa
A-dddddddddddddd
A-a-aaaaaaaaaaaa
a-aaaaaaaaaa-
-aaaaaaaaaa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);