using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bclientName=([^\r\n,=]+(?:,(?!\h*\w+=)[^\r\n,=]*)*)";
string substitution = @"";
string input = @"com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD LAW SCHOOL, THE, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD LAW SCHOOL, THE]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD, THE]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H]
name=User1, clientName=HARVARD LAW SCHOOL, THE, clientId=12345
name=User1, clientName=HARVARD LAW SCHOOL, THE
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H, clientId=12345]
name=User1, clientName=, clientId=12345
name=User1, clientName=H";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}