import Foundation
let pattern = #"\bclientName=([^\r\n,=]+(?:,(?!\h*\w+=)[^\r\n,=]*)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD LAW SCHOOL, THE, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD LAW SCHOOL, THE]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD, THE]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H]
name=User1, clientName=HARVARD LAW SCHOOL, THE, clientId=12345
name=User1, clientName=HARVARD LAW SCHOOL, THE
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H, clientId=12345]
name=User1, clientName=, clientId=12345
name=User1, clientName=H
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)