re = /\bclientName=([^\r\n,=]+(?:,(?!\h*\w+=)[^\r\n,=]*)*)/m
str = 'com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD LAW SCHOOL, THE, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD LAW SCHOOL, THE]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD, THE]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H]
name=User1, clientName=HARVARD LAW SCHOOL, THE, clientId=12345
name=User1, clientName=HARVARD LAW SCHOOL, THE
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H, clientId=12345]
name=User1, clientName=, clientId=12345
name=User1, clientName=H'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result