#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([0-9]+\.){2}[0-9]+\S*"
Local $sString = "Found git tag v6.0.0 associated with version 6.0.0 on branch main" & @CRLF & _
"Found git tag v6.0.0 associated with version 6.0.0-main.2 on branch main" & @CRLF & _
"The next release version is 7.0.0" & @CRLF & _
"The next release version is 7.0.0-main.12" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")