$re = '/\b([0-9]+\.){2}[0-9]+\S*/m';
$str = 'Found git tag v6.0.0 associated with version 6.0.0 on branch main
Found git tag v6.0.0 associated with version 6.0.0-main.2 on branch main
The next release version is 7.0.0
The next release version is 7.0.0-main.12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);